[PATCH] D19365: [tsan] Rename ReportThread->pid to ReportThread->os_id

Kuba Brecka via llvm-commits llvm-commits at lists.llvm.org
Thu Apr 21 07:47:41 PDT 2016


kubabrecka created this revision.
kubabrecka added reviewers: dvyukov, kcc, glider, samsonov.
kubabrecka added subscribers: llvm-commits, zaks.anna, dcoughlin.

The field "pid" in ReportThread is used to store the OS-provided thread ID (pthread_self or gettid).  The name "pid" suggests it's a process ID, which it isn't.  Let's rename it.

http://reviews.llvm.org/D19365

Files:
  lib/tsan/rtl/tsan_debugging.cc
  lib/tsan/rtl/tsan_interface.h
  lib/tsan/rtl/tsan_report.cc
  lib/tsan/rtl/tsan_report.h
  lib/tsan/rtl/tsan_rtl_report.cc
  test/tsan/debugging.cc

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D19365.54505.patch
Type: text/x-patch
Size: 4049 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20160421/9ee2bf69/attachment.bin>


More information about the llvm-commits mailing list