[PATCH] D18836: Make aliases explicit in the module summary
Teresa Johnson via llvm-commits
llvm-commits at lists.llvm.org
Wed Apr 13 07:56:08 PDT 2016
tejohnson added inline comments.
================
Comment at: lib/Bitcode/Writer/BitcodeWriter.cpp:2942
@@ -2935,1 +2941,3 @@
+ // We shouldn't have any anonymous functions as they are not supported in
+ // ThinLTO and should be renamed.
if (!F.hasName())
----------------
Maybe "should have been renamed by anonymous function renaming pass"?
================
Comment at: test/Bitcode/thinlto-function-summary.ll:1
@@ -1,2 +1,2 @@
; RUN: llvm-as -module-summary < %s | llvm-bcanalyzer -dump | FileCheck %s -check-prefix=BC
; Check for summary block/records.
----------------
Needs merge. But I think there is still an issue here, as opt will also need to be invoked with the -name-anon-functions to avoid the new assert. Which makes me wonder - should the -module-summary option to opt force enable -name-anon-functions? Or if not, at least warn if that wasn't specified?
http://reviews.llvm.org/D18836
More information about the llvm-commits
mailing list