[PATCH] D18836: Make aliases explicit in the module summary

Teresa Johnson via llvm-commits llvm-commits at lists.llvm.org
Thu Apr 7 22:24:33 PDT 2016


tejohnson added inline comments.

================
Comment at: lib/Bitcode/Reader/BitcodeReader.cpp:5935
@@ +5934,3 @@
+    // FS_COMBINED_ALIAS: [modid, linkage, offset]
+    // Aliases must be emitted (and parsed) after all FS_PERMODULE entries, as
+    // they expect all aliasee summaries to be available.
----------------
s/FS_PERMODULE/FS_COMBINED/

================
Comment at: lib/Bitcode/Writer/BitcodeWriter.cpp:2941
@@ -2933,2 +2940,3 @@
+    // ThinLTO and should be renamed, but if any remains here, just skip them.
     if (!F.hasName())
       continue;
----------------
Saw that you sent a patch to rename them on which this is dependent (will review that tomorrow morn). Assuming that goes in first, perhaps this should stay an assert? Ditto for the continue you added below to the alias loop.


http://reviews.llvm.org/D18836





More information about the llvm-commits mailing list