[PATCH] D18623: [PGO] refactor PGOFuncName meta data code to be used in clang

Vedant Kumar via llvm-commits llvm-commits at lists.llvm.org
Wed Mar 30 14:50:50 PDT 2016


vsk added a comment.

Thanks --


================
Comment at: include/llvm/ProfileData/InstrProf.h:250
@@ -247,1 +249,3 @@
 
+inline StringRef getPGOFuncNameMetaDataKind() { return "PGOFuncName"; }
+
----------------
nit 1: `MetaData` -> `Metadata`, I'd prefer to preserve consistency with the existing naming convention.
nit 2: `MetaDataKind` -> `MetadataName`, since `enum MetadataKind` already exists, and this could cause confusion.

================
Comment at: include/llvm/ProfileData/InstrProf.h:257
@@ +256,3 @@
+
+/// Write out the PGOFuncName meta data if PGOFuncName is different from
+/// function's raw name. This should only apply to internal linkage functions
----------------
nit: "Write out" -> "Create"


http://reviews.llvm.org/D18623





More information about the llvm-commits mailing list