[PATCH] D18574: Replace MachineRegisterInfo::isSSA() with a MachineFunctionProperty
Derek Schuff via llvm-commits
llvm-commits at lists.llvm.org
Tue Mar 29 13:53:26 PDT 2016
dschuff added a comment.
The syntax for MachineFunctionProperties is fairly verbose. I'm wondering if we want to do one or more of the following:
1. Shorten the name of `MachineFunctionProperties` and/or `MachineFunctionProperties::Property`
2. Rename `MachineFunctionProperties::hasProperty` (maybe `test` to match BitVector, or perhaps `operator[]`)
3. Rename `MachineFunction::getProperties` or perhaps replace it with a `hasProperty` or `testProperty` method on `MachineFunction` directly
4. Make `MachineFunctionProperties::Property` a C-style enum rather than a scoped enum
I would say maybe 1 and 2, but I don't have a great idea for what names I'd use for 1.
http://reviews.llvm.org/D18574
More information about the llvm-commits
mailing list