[PATCH] D18302: [ELF][MIPS] Delete GotSection::addMipsLocalEntry method

Simon Atanasyan via llvm-commits llvm-commits at lists.llvm.org
Sun Mar 20 08:26:07 PDT 2016


atanasyan added a comment.

In http://reviews.llvm.org/D18302#378884, @ruiu wrote:

> I'm not very sure whether this is positive for readability or not. This seems to be neutral to me. If you could just remove the code that would be fine, but this patch add a new `if (Body.isPreemptible())`, which is a bit difficult to understand. Is there any way to simplify it further?


Unfortunately the `if (Body.isPreemptible())` is mandatory because we do not need to add to dynamic symbol table symbols which have entries in the "local" part of MIPS GOT. I can add a comment to describe this `if` statement. Even after that the code is shorter.


Repository:
  rL LLVM

http://reviews.llvm.org/D18302





More information about the llvm-commits mailing list