[PATCH] D17778: TypedError for recoverable error handling
Lang Hames via llvm-commits
llvm-commits at lists.llvm.org
Mon Mar 14 11:48:59 PDT 2016
lhames added a comment.
Big readability update:
(1) Main classes / utilities renamed from TypedError -> Error.
(2) Added ErrorHandlerTraits machinery to deduce handler type for handler RTTI checks. This removes the need to wrap handlers in a 'handleTypedError<T>' call.
(3) Rename catch* to handle*.
The new handler idiom is:
handleErrors(std::move(E),
[](const CustomErrType &EI) {
// ...
},
[](const CustomErrType2 &EI) {
//...
},
...);
Otherwise the scheme is unchanged from the original patch.
http://reviews.llvm.org/D17778
More information about the llvm-commits
mailing list