[llvm] r263127 - Rename -discard-value-names into -lto-discard-value-names in libLLVMLTO

Mehdi Amini via llvm-commits llvm-commits at lists.llvm.org
Thu Mar 10 09:06:52 PST 2016


Author: mehdi_amini
Date: Thu Mar 10 11:06:52 2016
New Revision: 263127

URL: http://llvm.org/viewvc/llvm-project?rev=263127&view=rev
Log:
Rename -discard-value-names into -lto-discard-value-names in libLLVMLTO

This is avoiding a naming conflict with opt and llc.
While opt and llc don't link to LTO usually, users that are building a
monolithic libLLVM.dylib and linking the tools to it would have a
runtime error because of the duplicate cl::opt registration.

From: Mehdi Amini <mehdi.amini at apple.com>

Modified:
    llvm/trunk/lib/LTO/LTOCodeGenerator.cpp

Modified: llvm/trunk/lib/LTO/LTOCodeGenerator.cpp
URL: http://llvm.org/viewvc/llvm-project/llvm/trunk/lib/LTO/LTOCodeGenerator.cpp?rev=263127&r1=263126&r2=263127&view=diff
==============================================================================
--- llvm/trunk/lib/LTO/LTOCodeGenerator.cpp (original)
+++ llvm/trunk/lib/LTO/LTOCodeGenerator.cpp Thu Mar 10 11:06:52 2016
@@ -67,8 +67,8 @@ const char* LTOCodeGenerator::getVersion
 
 namespace llvm {
 cl::opt<bool> LTODiscardValueNames(
-    "discard-value-names",
-    cl::desc("Strip names from Value (other than GlobalValue)."),
+    "lto-discard-value-names",
+    cl::desc("Strip names from Value during LTO (other than GlobalValue)."),
 #ifdef NDEBUG
     cl::init(true),
 #else




More information about the llvm-commits mailing list