[PATCH] D17829: [libfuzzer] arbitrary function adapter
Mike Aizatsky via llvm-commits
llvm-commits at lists.llvm.org
Thu Mar 3 13:08:22 PST 2016
aizatsky added a comment.
> I'm not sure about the whole idea of splitting an array of bytes into multiple arguments. It seems like a lot of mutations in the input byte array would result in very non-local changes to the argument list, ex. inserting a byte at the beginning would shift all arguments to the right which could give them an entirely different meaning.
> Would it be better to expose individual arguments to the fuzzing engine?
I don't think libfuzzer would do something different if it new anything about arguments. Yes, it could shift, but you can look at it as creating an interesting permutation.
================
Comment at: lib/Fuzzer/FuzzerFnAdapter.h:104
@@ +103,3 @@
+ typename std::enable_if <
+ N<std::tuple_size<TupleT>::value, bool>::type
+ UnpackImpl(const uint8_t *Data, size_t Size, TupleT *Tuple) {
----------------
eugenis wrote:
> Space around "<" in "N<std::tuple_size" would greatly help readability.
> Did you run this through clang-format?
>
Yes, this file is 100% clang-formatted. I'll fix this line manually and try to remember to refix it after format.
http://reviews.llvm.org/D17829
More information about the llvm-commits
mailing list