[PATCH] D16169: [Utils] Fix incorrect dbg.declare store conversion
Keno Fischer via llvm-commits
llvm-commits at lists.llvm.org
Thu Jan 14 09:29:41 PST 2016
loladiro added inline comments.
================
Comment at: lib/Transforms/Utils/Local.cpp:1138
@@ +1137,3 @@
+ User *U = AIUse.getUser();
+ if (StoreInst *SI = dyn_cast<StoreInst>(U)) {
+ if (AIUse.getOperandNo() == 1)
----------------
aprantl wrote:
> Does turning this if cascade into a switch() make it any more readable?
I think that would introduce a lot of extra casting, which would probably make it less readable (assuming you were thinking of a cast on ->getOperand()), if there's a better syntax, do let me know.
Repository:
rL LLVM
http://reviews.llvm.org/D16169
More information about the llvm-commits
mailing list