[PATCH] D16117: [ELF/AArch64] - Implemented R_AARCH64_TLSIE_ADR_GOTTPREL_PAGE21 and R_AARCH64_TLSIE_LD64_GOTTPREL_LO12_NC relocations

George Rimar via llvm-commits llvm-commits at lists.llvm.org
Wed Jan 13 03:41:52 PST 2016


grimar added inline comments.

================
Comment at: ELF/Target.cpp:1280-1283
@@ -1263,4 +1279,6 @@
                                       const SymbolBody &S) const {
-  return Type == R_AARCH64_ADR_GOT_PAGE || Type == R_AARCH64_LD64_GOT_LO12_NC ||
+  return Type == R_AARCH64_TLSIE_LD64_GOTTPREL_LO12_NC ||
+         Type == R_AARCH64_TLSIE_ADR_GOTTPREL_PAGE21 ||
+         Type == R_AARCH64_ADR_GOT_PAGE || Type == R_AARCH64_LD64_GOT_LO12_NC ||
          relocNeedsPlt(Type, S);
 }
----------------
ruiu wrote:
> This is probably more readable as we have many expressions here.
> 
>   switch (Type) {
>   case R_AARCH64_...:
>   case R_AARCH64_...:
>   case R_AARCH64_...:
>   case R_AARCH64_...:
>     return true;
>   default:
>    return relocNeedsPlt(Type, S);
>   }
Done.


Repository:
  rL LLVM

http://reviews.llvm.org/D16117





More information about the llvm-commits mailing list