[PATCH] D16117: [ELF/AArch64] - Implemented R_AARCH64_TLSIE_ADR_GOTTPREL_PAGE21 and R_AARCH64_TLSIE_LD64_GOTTPREL_LO12_NC relocations

Rui Ueyama via llvm-commits llvm-commits at lists.llvm.org
Tue Jan 12 10:40:31 PST 2016


ruiu accepted this revision.
ruiu added a comment.
This revision is now accepted and ready to land.

LGTM


================
Comment at: ELF/Target.cpp:1280-1283
@@ -1263,4 +1279,6 @@
                                       const SymbolBody &S) const {
-  return Type == R_AARCH64_ADR_GOT_PAGE || Type == R_AARCH64_LD64_GOT_LO12_NC ||
+  return Type == R_AARCH64_TLSIE_LD64_GOTTPREL_LO12_NC ||
+         Type == R_AARCH64_TLSIE_ADR_GOTTPREL_PAGE21 ||
+         Type == R_AARCH64_ADR_GOT_PAGE || Type == R_AARCH64_LD64_GOT_LO12_NC ||
          relocNeedsPlt(Type, S);
 }
----------------
This is probably more readable as we have many expressions here.

  switch (Type) {
  case R_AARCH64_...:
  case R_AARCH64_...:
  case R_AARCH64_...:
  case R_AARCH64_...:
    return true;
  default:
   return relocNeedsPlt(Type, S);
  }


http://reviews.llvm.org/D16117





More information about the llvm-commits mailing list