[PATCH] D15757: Extract helper function to merge MemoryOperand lists [NFC]

Philip Reames via llvm-commits llvm-commits at lists.llvm.org
Wed Dec 23 20:25:06 PST 2015


reames added inline comments.

================
Comment at: lib/CodeGen/MachineInstr.cpp:884
@@ +883,3 @@
+                     MemEnd);
+  return std::make_pair(MemBegin, MemEnd-MemBegin);
+}
----------------
flyingforyou wrote:
> We might update `NumMemRefs` in this function. Right?
Sorry, what?  Oh, I see what you're getting at.  Yes, MemEnd-MemBegin should be equal to numMemRefs.  I copied the code and didn't notice the confusing name and missing assert.  Will add.  


http://reviews.llvm.org/D15757





More information about the llvm-commits mailing list