[PATCH] D15084: Split the linker in 2
Teresa Johnson via llvm-commits
llvm-commits at lists.llvm.org
Wed Dec 9 14:12:28 PST 2015
tejohnson added inline comments.
================
Comment at: lib/Linker/LinkModules.cpp:702
@@ -1805,1 +701,3 @@
}
+ GV.setLinkage(getLinkage(&GV));
+}
----------------
Oh I see, this is handling the linkage changes in general for ThinLTO imported symbols. I'm not sure the function name doThinLTOPromotion is quite accurate then since it is doing more than promotion, but I can't think of a better name at the moment. doThinLTOSymbolHandling or something?
http://reviews.llvm.org/D15084
More information about the llvm-commits
mailing list