[PATCH] D15082: Fix the linking of unit tests in lib/asan
Alexey Samsonov via llvm-commits
llvm-commits at lists.llvm.org
Wed Dec 9 11:37:23 PST 2015
samsonov added a comment.
Sorry for delay. I agree, this is way too confusing. So, currently:
- COMPILER_RT_TEST_COMPILER_CFLAGS is a user-defined CMake variable and is used to compile/link lit-tests (if we're using a cross-compiler)
- COMPILER_RT_TEST_CFLAGS are used to compile unit tests and is just a variable we construct.
I think the right change would be to:
(a) rename COMPILER_RT_TEST_CFLAGS to COMPILER_RT_UNITTEST_CFLAGS to reflect the way it's used.
(b) add COMPILER_RT_TEST_COMPILER_CFLAGS to COMPILER_RT_UNITTEST_CFLAGS so that cross-compiler would be able to build the tests
(c) (if needed) introduce/do smth. similar to COMPILER_RT_UNITTEST_LINKFLAGS if needed.
http://reviews.llvm.org/D15082
More information about the llvm-commits
mailing list