[PATCH] D15196: adding readability-identifier-naming to llvm clang-tidy configuration.
Mike Aizatsky via llvm-commits
llvm-commits at lists.llvm.org
Tue Dec 8 09:47:59 PST 2015
This revision was automatically updated to reflect the committed changes.
Closed by commit rL255028: adding readability-identifier-naming to llvm clang-tidy configuration. (authored by aizatsky).
Changed prior to commit:
http://reviews.llvm.org/D15196?vs=41774&id=42187#toc
Repository:
rL LLVM
http://reviews.llvm.org/D15196
Files:
llvm/trunk/.clang-tidy
Index: llvm/trunk/.clang-tidy
===================================================================
--- llvm/trunk/.clang-tidy
+++ llvm/trunk/.clang-tidy
@@ -1 +1,13 @@
-Checks: '-*,clang-diagnostic-*,llvm-*,misc-*'
+Checks: '-*,clang-diagnostic-*,llvm-*,misc-*,readability-identifier-naming'
+CheckOptions:
+ - key: readability-identifier-naming.ClassCase
+ value: CamelCase
+ - key: readability-identifier-naming.EnumCase
+ value: CamelCase
+ - key: readability-identifier-naming.FunctionCase
+ value: lowerCase
+ - key: readability-identifier-naming.UnionCase
+ value: CamelCase
+ - key: readability-identifier-naming.VariableCase
+ value: CamelCase
+
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D15196.42187.patch
Type: text/x-patch
Size: 783 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20151208/37f00b40/attachment.bin>
More information about the llvm-commits
mailing list