[PATCH] D14922: [ELF/AArch64] Factor out overflow check into a separate function.
Rui Ueyama via llvm-commits
llvm-commits at lists.llvm.org
Mon Nov 23 10:04:14 PST 2015
ruiu added a comment.
I'm not in favor of this change, and I wouldn't do that. The previous code was super clear that it errors if isInt check fails. Now you have to take a look at the definition of checkAArch64OutOfRange function. You saved one line per a function call, but it doesn't seem like a good tradeoff from code readability point of view.
Repository:
rL LLVM
http://reviews.llvm.org/D14922
More information about the llvm-commits
mailing list