[PATCH] D14749: [ELF2/AArch64] Add lazy relocation for AArch64 target.
Rui Ueyama via llvm-commits
llvm-commits at lists.llvm.org
Tue Nov 17 09:31:56 PST 2015
ruiu added a comment.
LGTM
================
Comment at: ELF/Target.cpp:617
@@ +616,3 @@
+
+unsigned AArch64TargetInfo::getPLTRefReloc(unsigned Type) const { return Type; }
+
----------------
ikudrin wrote:
> ruiu wrote:
> > Remove this function.
> Why? If I remove it, I'll need to fill PCRelReloc instead, but this function is called for different types of relocations, R_AARCH64_JUMP26 and R_AARCH64_CALL26 in particular. And these relocations are supported by the relocateOne() method anyway.
I'm sorry I thought that this is a dead function. It is not.
The name of this function is inconsistent. Could you do s/PLT/Plt/ in a follow-up patch?
http://reviews.llvm.org/D14749
More information about the llvm-commits
mailing list