[PATCH] D13953: Preserve load alignment and dereferenceable metadata during some transformations

hfinkel@anl.gov via llvm-commits llvm-commits at lists.llvm.org
Tue Oct 27 13:26:00 PDT 2015


hfinkel added inline comments.

================
Comment at: lib/IR/Metadata.cpp:967
@@ +966,3 @@
+
+MDNode *MDNode::getMostGenericDereferenceable(MDNode *A, MDNode *B) {
+  if (!A || !B)
----------------
It seems silly to copy-and-paste the same function twice with a different name. How about just naming it getMostGenericAlignmentOrDereferenceable?



http://reviews.llvm.org/D13953





More information about the llvm-commits mailing list