[PATCH] D13361: Support for emitting inline stack probes

Reid Kleckner via llvm-commits llvm-commits at lists.llvm.org
Tue Oct 6 11:44:59 PDT 2015


rnk added a comment.

I think it'd be cleaner to avoid changing the target independent TargetFrameLowering interface, and instead keep it as an X86-internal pseudo instruction that we lower in X86ExpandPseudo.cpp. Then PEI doesn't have to worry about this MBB expansion issue. What do you think?

I think the `WIN_ALLOCA` pseudo instruction can probably just take on that new role, and we could rename it to something more accurate like `CHKSTK`.


Repository:
  rL LLVM

http://reviews.llvm.org/D13361





More information about the llvm-commits mailing list