[PATCH] D12464: Add way to test for builtin TargetOpcode
Ahmed Bougacha via llvm-commits
llvm-commits at lists.llvm.org
Thu Oct 1 17:35:53 PDT 2015
ab added a subscriber: ab.
ab accepted this revision.
ab added a reviewer: ab.
ab added a comment.
This revision is now accepted and ready to land.
With '<' -> '<=', seems reasonable.
Can you add a comment? I'm not sure we refer to these as "builtins" anywhere else (not that I have a better name though).
================
Comment at: include/llvm/Target/TargetInstrInfo.h:65
@@ +64,3 @@
+ static bool isBuiltinOpcode(unsigned Opc) {
+ return Opc < TargetOpcode::BUILTIN_OP_END;
+ }
----------------
<= ?
http://reviews.llvm.org/D12464
More information about the llvm-commits
mailing list