[PATCH] D12276: [AArch64] Unify the integer min/max vector selection patterns with the intrinsic ones
James Molloy via llvm-commits
llvm-commits at lists.llvm.org
Mon Aug 24 05:35:59 PDT 2015
jmolloy accepted this revision.
jmolloy added a comment.
This revision is now accepted and ready to land.
LGTM with my coding style comment addressed.
================
Comment at: lib/Target/AArch64/AArch64ISelLowering.cpp:2187
@@ -2186,1 +2186,3 @@
}
+ case Intrinsic::aarch64_neon_smax:
+ case Intrinsic::aarch64_neon_umax:
----------------
I don't really like having the switch inside the switch - each case is just one line anyway, I think we're removing readability.
http://reviews.llvm.org/D12276
More information about the llvm-commits
mailing list