[PATCH] D10953: [mips][microMIPS] Implement DDIV, DMOD, DDIVU and DMODU instructions
Daniel Sanders via llvm-commits
llvm-commits at lists.llvm.org
Tue Aug 11 04:02:03 PDT 2015
dsanders accepted this revision.
dsanders added a comment.
This revision is now accepted and ready to land.
LGTM with a couple spelling/style nits fixed.
================
Comment at: lib/Target/Mips/MicroMips64r6InstrFormats.td:27
@@ +26,3 @@
+
+class DOUBLE_DIVIDE_MODULO_ENC<string instr_asm, bits<9> funct>
+ : MMR6Arch<instr_asm> {
----------------
Please use the naming convention. This class is an encoding format and should therefore be named something like:
POOL32A_DIVMOD_FM
The convention is <opcode>_<misc>_FM
================
Comment at: lib/Target/Mips/MicroMips64r6InstrInfo.td:54-61
@@ -44,2 +53,10 @@
def DAUI_MM64R6 : R6MMR6Rel, DAUI_MMR6_DESC, DAUI_MMR6_ENC, ISA_MICROMIPS64R6;
+ def DDIV_MM64R6 : R6MMR6Rel, DDIV_MM64R6_DESC, DDIV_MM64R6_ENC,
+ ISA_MICROMIPS64R6;
+ def DMOD_MM64R6 : R6MMR6Rel, DMOD_MM64R6_DESC, DMOD_MM64R6_ENC,
+ ISA_MICROMIPS64R6;
+ def DDIVU_MM64R6 : R6MMR6Rel, DDIVU_MM64R6_DESC, DDIVU_MM64R6_ENC,
+ ISA_MICROMIPS64R6;
+ def DMODU_MM64R6 : R6MMR6Rel, DMODU_MM64R6_DESC, DMODU_MM64R6_ENC,
+ ISA_MICROMIPS64R6;
}
----------------
Nit: *_ENC normally appears before *_DESC
http://reviews.llvm.org/D10953
More information about the llvm-commits
mailing list