[PATCH] D11696: [x86] machine combiner reassociation: mark EFLAGS operand as 'dead'
Gerolf Hoflehner
ghoflehner at apple.com
Mon Aug 3 16:41:31 PDT 2015
Gerolf accepted this revision.
Gerolf added a comment.
Thanks for your follow-ups. I leave it up to you if you want to address my remaining comments.
LGTM.
================
Comment at: lib/Target/X86/X86InstrInfo.cpp:6441
@@ +6440,3 @@
+/// This is an architecture-specific helper function of reassociateOps. Set the
+/// appropriate flags for any extra operands of instructions that are being
+/// reassociated.
----------------
How about: This is an ..... Set special operand attributes post re-association?
================
Comment at: lib/Target/X86/X86InstrInfo.cpp:6443
@@ +6442,3 @@
+/// reassociated.
+static void setExtraReassOperands(MachineInstr &OldMI1, MachineInstr &OldMI2,
+ MachineInstr &NewMI1, MachineInstr &NewMI2) {
----------------
Would setSpecialOperandAttributes() be a better name?
================
Comment at: lib/Target/X86/X86InstrInfo.cpp:6450
@@ +6449,3 @@
+
+ assert(NewMI1.getNumOperands() == 4 && NewMI2.getNumOperands() == 4 &&
+ "Unexpected instruction type for reassociation");
----------------
Looks a bit of an overkill here.
http://reviews.llvm.org/D11696
More information about the llvm-commits
mailing list