[PATCH] D11250: Rename LoopInfo::Analyze() to LoopInfo::analyze() and turn its parameter type to const&.
hfinkel at anl.gov
hfinkel at anl.gov
Sat Jul 25 18:33:57 PDT 2015
hfinkel added a subscriber: hfinkel.
================
Comment at: include/llvm/CodeGen/MachineDominators.h:267
@@ +266,3 @@
+template <> struct GraphTraits<const MachineDomTreeNode *> {
+ typedef const MachineDomTreeNode NodeType;
+ typedef NodeType::const_iterator ChildIteratorType;
----------------
The fact that this requires copy-and-paste from above is somewhat sad, could we do better (have them both inherit from a templated base class perhaps)?
================
Comment at: include/llvm/IR/Dominators.h:151
@@ +150,3 @@
+template <> struct GraphTraits<const DomTreeNode *> {
+ typedef const DomTreeNode NodeType;
+ typedef NodeType::const_iterator ChildIteratorType;
----------------
Same comment here.
http://reviews.llvm.org/D11250
More information about the llvm-commits
mailing list