[PATCH] D11481: [LoopUnswitch] Improve loop unswitch pass to find trivial unswitch conditions more effectively
Bjarke Hammersholt Roune
broune at google.com
Fri Jul 24 11:55:12 PDT 2015
broune added inline comments.
================
Comment at: lib/Transforms/Scalar/LoopUnswitch.cpp:808
@@ +807,3 @@
+
+ HeaderTerm = Header->getTerminator();
+ }
----------------
chenli wrote:
> broune wrote:
> > Nit: HeaderTerm is set twice and only used twice. I would use Header->getTerminator() directly for the two uses instead, as then there's one variable less to keep track of.
> There are a few uses in the later code as well. I would prefer to keep the variable.
You're right, I thought the function ended before it actually does.
http://reviews.llvm.org/D11481
More information about the llvm-commits
mailing list