[PATCH] [LAA] Merge memchecks for accesses separated by a constant offset
silviu.baranga at arm.com
silviu.baranga at arm.com
Fri Jun 26 08:55:16 PDT 2015
Renamed CheckGroup to CheckingPtrGroup.
Remove the use of EquivalenceClasses and all the other
vectors used in the merging algorithm. We now use a single
SmallVector of CheckingPtrGroups instead (which seems to
be enough). This should make everything more readable.
Fixed the iteration of DepCands (was missing a isLeader check).
Moved the code that adds a pointer to a CheckingPtrGroup
(and checks that this can be done) to CheckingPtrGroup.
Change the constructor of CheckingPtrGroup to take the index
of the first element that makes up the group. We only need
to construct groups with at least one element and the previous
constructor was only in a single place.
Various comment changes / spelling fixes according to comments.
http://reviews.llvm.org/D10386
Files:
include/llvm/Analysis/LoopAccessAnalysis.h
lib/Analysis/LoopAccessAnalysis.cpp
test/Analysis/LoopAccessAnalysis/number-of-memchecks.ll
test/Analysis/LoopAccessAnalysis/resort-to-memchecks-only.ll
test/Analysis/LoopAccessAnalysis/unsafe-and-rt-checks.ll
test/Transforms/LoopDistribute/basic-with-memchecks.ll
EMAIL PREFERENCES
http://reviews.llvm.org/settings/panel/emailpreferences/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D10386.28564.patch
Type: text/x-patch
Size: 24521 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20150626/ed079ddc/attachment.bin>
More information about the llvm-commits
mailing list