[PATCH] [Inlining] Teach the inliner pass to inline through statepoints.

Sanjoy Das sanjoy at playingwithpointers.com
Thu Jun 25 19:15:27 PDT 2015


- remove `InlineSite`
- rename the accessor on Statepoint to `getTargetFunction`.  I chose this name because the statepoint documentation uses the term "target"; but more bikeshedding is welcome.


http://reviews.llvm.org/D10633

Files:
  include/llvm/IR/CallSite.h
  lib/Analysis/IPA/InlineCost.cpp
  lib/Transforms/IPO/InlineAlways.cpp
  lib/Transforms/IPO/Inliner.cpp
  test/Transforms/Inline/statepoints-basic.ll

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D10633.28528.patch
Type: text/x-patch
Size: 10621 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20150626/6814815a/attachment.bin>


More information about the llvm-commits mailing list