[PATCH] [LoopDist] Move loop-versioning helper functions to Cloning, NFC
hfinkel at anl.gov
hfinkel at anl.gov
Mon Jun 22 18:30:51 PDT 2015
================
Comment at: include/llvm/Transforms/Utils/Cloning.h:248
@@ +247,3 @@
+
+/// \brief Remaps instructions in a loop including the preheader.
+void remapInstructionsInLoop(const SmallVectorImpl<BasicBlock *> &Blocks,
----------------
Does it only include the preheader if the preheader is included in the Blocks list?
================
Comment at: lib/Transforms/Utils/CloneFunction.cpp:726
@@ +725,3 @@
+/// \brief Remaps instructions in a loop including the preheader.
+void llvm::remapInstructionsInLoop(const SmallVectorImpl<BasicBlock *> &Blocks,
+ ValueToValueMapTy &VMap) {
----------------
Why not just name this remapInstructionsInBlocks?
http://reviews.llvm.org/D10576
EMAIL PREFERENCES
http://reviews.llvm.org/settings/panel/emailpreferences/
More information about the llvm-commits
mailing list