[PATCH] Remove SCEVCache and FindConstantPointers from complete loop unrolling heuristic.

Michael Zolotukhin mzolotukhin at apple.com
Fri Jun 5 21:06:45 PDT 2015


- Rebase on master.
- Rename SCEVSimplify to simplifyInstWithSCEV.
- Use assert + getSExtValue instead of getLimitedValue and remove no
- Introduce SimplifiedOffsets.
- Remove unneeded code.
- Move initialize of IterationNumber to constructor.
- Doxygenify comment for SimplifiedValues.
- Fallback to Base visitor if failed to constant fold (and only then call simplifyInstWithSCEV).


http://reviews.llvm.org/D10205

Files:
  lib/Transforms/Scalar/LoopUnrollPass.cpp

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D10205.27259.patch
Type: text/x-patch
Size: 14993 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20150606/62331328/attachment.bin>


More information about the llvm-commits mailing list