[llvm] r239071 - [bpf] add big- and host- endian support
Eric Christopher
echristo at gmail.com
Thu Jun 4 18:08:45 PDT 2015
On Thu, Jun 4, 2015 at 3:55 PM Alexei Starovoitov <
alexei.starovoitov at gmail.com> wrote:
> On Thu, Jun 4, 2015 at 3:37 PM, Eric Christopher <echristo at gmail.com>
> wrote:
> >
> >> What the patch does:
> >> -march=bpf -> host endian
> >> -march=bpf_le -> little endian
> >> -march=bpf_be -> big endian
> >>
> >
> > So, part of why I was going to review the Triple part of it is that the
> > naming convention for bpf big and little endian explicit triples doesn't
> > match the same convention for every other target. So, what references do
> you
> > have for these outside of llvm? I'd prefer to copy the existing
> nomenclature
> > if there's no compelling reason otherwise.
>
> I've copied aarch64, aarch64_be convention.
>
... why on earth did someone let aarch64 do that? That said, no one uses
the underscore except apparently aarch64. powerpc, mips, arm, sparc, etc
all avoid it.
> You mean you prefer without underscore?
> I think bpfle, bpfbe are less readable.
>
Possibly. Also easier to remember if there's not an exception here.
> Also there is no 'default' endianness.
>
I had guessed native would be default endianness?
> So what do you have in mind specificialy?
>
bpfle or bpfel for little endian etc to keep it matching every other target
(except for aarch64 which, per usual, decided to deviate in a way that's
not useful).
-eric
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20150605/fdf88ac3/attachment.html>
More information about the llvm-commits
mailing list