[PATCH] [x86] make reciprocal estimate code generation more flexible
Sanjay Patel
spatel at rotateright.com
Thu May 14 15:58:47 PDT 2015
================
Comment at: include/llvm/Target/TargetRecip.h:34
@@ +33,3 @@
+ VecSqrtD, // square root, double, vector
+ INVALID
+};
----------------
hfinkel wrote:
> hfinkel wrote:
> > To reduce confusion, I think it would be better to have a naming prefix on these. TailCallKind, for example, uses TCK_. Let's stick RO_ on these (including the INVALID one).
> >
> If you're using INVALID for the "number of", please name it NUM_RECIP_OPS (or similar).
>
With a named enum, I was expecting that users always have to use the prefix "RecipOps::" like I did in the x86 code.
But I see that's not done with TailCallKind...
http://reviews.llvm.org/D8982
EMAIL PREFERENCES
http://reviews.llvm.org/settings/panel/emailpreferences/
More information about the llvm-commits
mailing list