[PATCH] [PlaceSafepoints] Make internal helper pass a FunctionPass

Sanjoy Das sanjoy at playingwithpointers.com
Fri May 8 01:19:17 PDT 2015


================
Comment at: lib/Transforms/Scalar/PlaceSafepoints.cpp:113
@@ -112,3 +112,3 @@
 
 /** An analysis pass whose purpose is to identify each of the backedges in
     the function which require a safepoint poll to be inserted. */
----------------
In a separate change, please also fix the comment to be a C++ style comment.

================
Comment at: lib/Transforms/Scalar/PlaceSafepoints.cpp:135
@@ -129,3 +134,3 @@
 
-  bool runOnLoop(Loop *, LPPassManager &LPM) override;
-
+  bool runOnLoop(Loop *);
+  void runOnLoopAndSubLoops(Loop *L) {
----------------
I have a minor preference for calling this something more specific than `runOnLoop`.

http://reviews.llvm.org/D9588

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/






More information about the llvm-commits mailing list