[PATCH] Extend the statepoint intrinsic to allow statepoints to be marked as transitions from GC-aware code to code that is not GC-aware.
Philip Reames
listmail at philipreames.com
Wed May 6 18:09:24 PDT 2015
================
Comment at: lib/CodeGen/SelectionDAG/StatepointLowering.cpp:672
@@ +671,3 @@
+ (Flags & (uint64_t)StatepointFlags::MaskAll) == 0 && "unknown flag used");
+ const int Shift = 1;
+ static_assert(
----------------
pgavlin wrote:
> reames wrote:
> > This shift should be define in StackMaps.h for the StatepointOperands class with a more clear name.
> >
> > The other option is to just split this operand into 2. I have no idea why I masked them to start with, that's just unnecessary complexity. Might be better to do this as a separate change though.
> I like the sound of the latter option. Do you mind if I do this in a separate change?
I'd prefer that actually. Given the future change, this portion is fine for submission.
http://reviews.llvm.org/D9501
EMAIL PREFERENCES
http://reviews.llvm.org/settings/panel/emailpreferences/
More information about the llvm-commits
mailing list