[PATCH] Emit correct linkage-name attribute based on DWARF version.
Eric Christopher
echristo at gmail.com
Tue Mar 10 14:24:47 PDT 2015
================
Comment at: lib/CodeGen/AsmPrinter/DwarfUnit.cpp:1281
@@ +1280,3 @@
+ addString(SPDie,
+ DD->getDwarfVersion() >= 4 ? dwarf::DW_AT_linkage_name
+ : dwarf::DW_AT_MIPS_linkage_name,
----------------
dblaikie wrote:
> Should we pull this out into a utility function somewhere? "addLinkageNameString" ? (it could do the attribute choosing, and the "getRealLinkageName" Call as well, perhaps)
Yes. Agreed, it's almost assuredly why it's like this in the first place.
http://reviews.llvm.org/D8227
EMAIL PREFERENCES
http://reviews.llvm.org/settings/panel/emailpreferences/
More information about the llvm-commits
mailing list