[PATCH] [SCEV] Unify getUnsignedRange and getSignedRange

Sanjoy Das sanjoy at playingwithpointers.com
Sat Mar 7 16:22:47 PST 2015


Hi atrick, nlewycky,

Doing this removes some duplicated code, and also helps optimization:
e.g. in the test case added, `%idx ULT 128` in `@x` is not currently
optimized to `true` by `-indvars`.

http://reviews.llvm.org/D8142

Files:
  include/llvm/Analysis/ScalarEvolution.h
  lib/Analysis/ScalarEvolution.cpp
  test/Analysis/ScalarEvolution/range-signedness.ll

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D8142.21436.patch
Type: text/x-patch
Size: 23503 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20150308/efdf39e5/attachment.bin>


More information about the llvm-commits mailing list