[PATCH] [compiler-rt] Allow suppression file paths be relative to the location of the executable.
Anna Zaks
zaks.anna at gmail.com
Thu Feb 26 19:17:37 PST 2015
Comments addressed and committed in r230723.
================
Comment at: lib/sanitizer_common/sanitizer_common.h:221
@@ -217,1 +220,3 @@
+// Returns the path to the main executable.
+uptr ReadBinaryName(/*out*/char *buf, uptr buf_len);
u32 GetUid();
----------------
glider wrote:
> Nit: how about "GetBinaryName"? After all, you're not reading it on Mac.
The function only gets the file on Mac, but not on other platforms, so I don't think it should be renamed. (I've moved this from sanitizer_linux.h)
http://reviews.llvm.org/D7309
EMAIL PREFERENCES
http://reviews.llvm.org/settings/panel/emailpreferences/
More information about the llvm-commits
mailing list