[PATCH] ScopDetection: Only detect scops that have at least one read and one write
Sebastian Pop
sebpop at gmail.com
Wed Feb 18 18:00:33 PST 2015
Good catch to speed up compile time.
LGTM.
================
Comment at: lib/Analysis/ScopDetection.cpp:881
@@ +880,3 @@
+ // data.
+ if (!DetectUnprofitable && (!Context.hasStores || !Context.hasLoads))
+ invalid<ReportUnprofitable>(Context, /*Assert=*/true);
----------------
I always questioned the necessity of double negatives: "not unprofitable" = "profitable".
I find "profitable" easier to read.
http://reviews.llvm.org/D7735
EMAIL PREFERENCES
http://reviews.llvm.org/settings/panel/emailpreferences/
More information about the llvm-commits
mailing list