[PATCH] Modularizing LICM
Nema, Ashutosh
Ashutosh.Nema at amd.com
Tue Feb 3 21:12:30 PST 2015
Thanks Philip for reviewing this change.
I'm not planning to expose 'isSafeToExecuteUnconditionally' but we can change name of it.
Regards,
Ashutosh
-----Original Message-----
From: Philip Reames [mailto:listmail at philipreames.com]
Sent: Tuesday, February 03, 2015 11:05 PM
To: Nema, Ashutosh; bruno.cardoso at gmail.com; listmail at philipreames.com
Cc: hfinkel at anl.gov; llvm-commits at cs.uiuc.edu
Subject: Re: [PATCH] Modularizing LICM
With comments by others addressed, LGTM.
REPOSITORY
rL LLVM
================
Comment at: lib/Transforms/Scalar/LICM.cpp:410
@@ +409,3 @@
+ MayThrow, HeaderMayThrow) &&
+ isSafeToExecuteUnconditionally(I, DT, DL, CurLoop,
+ MayThrow, HeaderMayThrow))
----------------
This name is fine for now, but if this is exposed somewhere outside of LICM we'll need a clearer name. This isn't "safe to execute anywhere" its "safe to execute in the preheader".
http://reviews.llvm.org/D7291
EMAIL PREFERENCES
http://reviews.llvm.org/settings/panel/emailpreferences/
More information about the llvm-commits
mailing list