[PATCH] Factor out statepoint verification into separate function.
Philip Reames
listmail at philipreames.com
Fri Jan 30 10:17:27 PST 2015
One change needed, otherwise LGTM. Do you want to commit once you've updated?
REPOSITORY
rL LLVM
================
Comment at: lib/IR/Verifier.cpp:347
@@ -346,2 +346,3 @@
void visitUserOp2(Instruction &I) { visitUserOp1(I); }
+ void visitStatepoint(CallInst &CI);
void visitIntrinsicFunctionCall(Intrinsic::ID ID, CallInst &CI);
----------------
If we went by the naming convention used by the rest of the class this needs to be VerifyStatepoint and it needs to not be intermixed with the routines used by the visitor. Can you make that change?
Otherwise, LGTM.
http://reviews.llvm.org/D7276
EMAIL PREFERENCES
http://reviews.llvm.org/settings/panel/emailpreferences/
More information about the llvm-commits
mailing list