[PATCH] [lld][ARM] Add relocations to perform function calls
Will Newton
will.newton at linaro.org
Wed Jan 28 01:42:35 PST 2015
================
Comment at: lib/ReaderWriter/ELF/ARM/ARMRelocationHandler.cpp:113
@@ +112,3 @@
+ uint16_t maskLo = 0xFFFF) {
+ assert(!(resHi & ~maskHi) && !(resLo & ~maskLo));
+ *reinterpret_cast<llvm::support::ulittle16_t *>(location) =
----------------
I guess this assert and the one in applyArmReloc are the points where error checking happens. It would be good to use the error checking functionality instead as the asserts will get removed in release builds.
================
Comment at: lib/ReaderWriter/ELF/ARM/ARMRelocationHandler.cpp:161
@@ +160,3 @@
+ DECLARE_T(addressesThumb);
+ const bool exchanges = !addressesThumb;
+
----------------
"addressesThumb" is IMO a more descriptive name than "exchanges" so this variable does not help me to read the code.
http://reviews.llvm.org/D7223
EMAIL PREFERENCES
http://reviews.llvm.org/settings/panel/emailpreferences/
More information about the llvm-commits
mailing list