[PATCH] Parse EB variant as suffix for ARM triples
Renato Golin
renato.golin at linaro.org
Sun Jan 25 14:53:53 PST 2015
================
Comment at: lib/Support/Triple.cpp:1039
@@ -1024,1 +1038,3 @@
offset += 2;
+ if (MArch.endswith("eb"))
+ MArch = MArch.substr(0, MArch.size() - 2);
----------------
This patterns repeat far too often, can you move it into a helper function?
http://reviews.llvm.org/D7166
EMAIL PREFERENCES
http://reviews.llvm.org/settings/panel/emailpreferences/
More information about the llvm-commits
mailing list