[PATCH] Sink store based on alias analysis

Ella Bolshinsky ella.bolshinsky at intel.com
Mon Dec 8 01:09:28 PST 2014


================
Comment at: include/llvm/Analysis/AliasAnalysis.h:509
@@ -508,3 +508,3 @@
   /// canBasicBlockModify - A convenience wrapper.
   bool canBasicBlockModify(const BasicBlock &BB, const Value *P, uint64_t Size){
     return canBasicBlockModify(BB, Location(P, Size));
----------------
reames wrote:
> It would be good to keep this interface consistent with the one you're changing.  Leaving wrappers for the old interface names would be fine, or converting the BasicBlock versions to the ModRef form.  I'd slightly prefer leaving convenience wrappers under the old names.  
I am not sure I understand. 
I left the names of canBasicBlockModify as is.
However, I changed the name of the canInstructionRangeModRef  convenience wrapper as it is no longer only modify (I now noticed the comment was not changed - will update now).
Do you think it should have been done somehow otherwise?

http://reviews.llvm.org/D6420






More information about the llvm-commits mailing list