[PATCH] Rename EH related stuff to be more precise

Reid Kleckner rnk at google.com
Fri Nov 14 13:12:07 PST 2014


Hi echristo,

The current "WinEH" exception handling type is more about Itanium-style
LSDA tables layered on top of the Windows native unwind info format
instead of .eh_frame tables or EHABI unwind info. Use the name
"ItaniumWinEH" to better reflect the hybrid nature of the design.

Also rename isExceptionHandlingDWARF to usesItaniumLSDAForExceptions,
since the LSDA is part of the Itanium C++ ABI document, and not the
DWARF standard.

http://reviews.llvm.org/D6279

Files:
  include/llvm/MC/MCAsmInfo.h
  lib/CodeGen/AsmPrinter/AsmPrinter.cpp
  lib/CodeGen/AsmPrinter/DwarfCFIException.cpp
  lib/CodeGen/AsmPrinter/EHStreamer.cpp
  lib/CodeGen/Passes.cpp
  lib/Target/X86/MCTargetDesc/X86MCAsmInfo.cpp
  lib/Target/X86/X86FrameLowering.cpp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D6279.16248.patch
Type: text/x-patch
Size: 7953 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20141114/dfd170d0/attachment.bin>


More information about the llvm-commits mailing list