[PATCH] Refactor/simplify llvm-symbolizer code.
Alexey Samsonov
vonosmas at gmail.com
Mon Oct 20 17:52:21 PDT 2014
================
Comment at: tools/llvm-symbolizer/LLVMSymbolize.cpp:340
@@ +339,3 @@
+ if (!DbgObj) {
+ std::string DebuglinkName;
+ uint32_t CRCHash;
----------------
glider wrote:
> I suggest to move the .gnu_debuglink part into a helper function so that findDbgObj is more readable.
Done
================
Comment at: tools/llvm-symbolizer/LLVMSymbolize.cpp:357
@@ +356,3 @@
+static ErrorOr<const Binary *>
+getPointer(const ErrorOr<OwningBinary<Binary>> &BinaryOrErr) {
+ if (BinaryOrErr)
----------------
glider wrote:
> "getBinaryPointer", maybe?
Done
http://reviews.llvm.org/D5874
More information about the llvm-commits
mailing list