[PATCH] Add MachOObjectFile::findAndGetUuidCommand (better name suggestions welcome)

kledzik at apple.com kledzik at apple.com
Mon Oct 13 09:46:18 PDT 2014


The MachOObjectFile constructor is already walking the load commands.  If there is a LC_UUID, you can have the constructor save it off in an ivar.

The name findAndGetUuidCommand() is different than the other methods.  Can it just be getUUID() and have it return the 16-bytes?  Perhaps an ArrayRef<uint8_t> that has zero length if there is no UUID? Seems like that would be more convenient for the client.

-Nick

http://reviews.llvm.org/D5752






More information about the llvm-commits mailing list