[PATCH] Select Elimination in InstCombine
Gerolf Hoflehner
ghoflehner at apple.com
Thu Sep 11 12:23:20 PDT 2014
Changes:
- a few more improvements to code readability
- isChainSelectCmpBranch() is now static
- const parameters and variables
http://reviews.llvm.org/D5258
Files:
lib/Transforms/InstCombine/InstCombine.h
lib/Transforms/InstCombine/InstCombineCompares.cpp
lib/Transforms/InstCombine/InstructionCombining.cpp
test/Transforms/InstCombine/pr12338.ll
test/Transforms/InstCombine/select-cmp-br.ll
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D5258.13593.patch
Type: text/x-patch
Size: 12420 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20140911/9e509d47/attachment.bin>
More information about the llvm-commits
mailing list