[PATCH] [Polly][Refactor] Cleanup runtime code generation
Johannes Doerfert
doerfert at cs.uni-saarland.de
Wed Sep 10 07:27:11 PDT 2014
comment
================
Comment at: include/polly/CodeGen/Utils.h:31
@@ -35,1 +30,3 @@
+/// in the CFG. A branch statement decides which version is executed based on
+/// the runtime value of @p RTC.
///
----------------
grosser wrote:
> We already wasted too much time on this, if you feel strong about this, leave it as it is.
>
> However, I still think we should use a more descriptive name instead of RTC. To explain you this is not just me not _liking_ your names, I cite the LLVM developer policy:
>
> "Avoid abbreviations unless they are well known"
>
> http://llvm.org/docs/CodingStandards.html#name-types-functions-variables-and-enumerators-properly
>
> In LLVM there are a couple of uses of RT to abbreviate run time, and in fact RTCheck or RTCondition is a lot clearer to me. Maybe that works for you as well.
>
>
>
To much time,... indeed.
Wrt. "well know":
https://software.intel.com/sites/products/documentation/doclib/iss/2013/compiler/cpp-lin/GUID-65F1FC0F-16CB-441E-8E38-3A49DED905F6.htm
http://msdn.microsoft.com/en-us/library/6kasb93x.aspx
I don't mind __you__ changing my variable names to whatever if you think that helps to understand the code or is otherwise contradicting the developer policy but I don't see it here. (Btw. there are other variable names not according to the policy, you could change those too.)
http://reviews.llvm.org/D5076
More information about the llvm-commits
mailing list