[PATCH] Rename AtomicExpandLoadLinked into AtomicExpand (NFC)
Tim Northover
t.p.northover at gmail.com
Tue Aug 19 00:24:52 PDT 2014
Hi Robin,
I think this is mostly straightforward. I've just got one comment on the command-line option we end up with.
Cheers.
Tim.
================
Comment at: lib/CodeGen/AtomicExpandPass.cpp:55
@@ +54,3 @@
+char &llvm::AtomicExpandID = AtomicExpand::ID;
+INITIALIZE_TM_PASS(AtomicExpand, "atomic",
+ "Expand Atomic calls in terms of either load-linked & store-conditional or cmpxchg",
----------------
I think "-atomic" is too generic as an option name. It should probably be "-atomic-expand" or something.
Actually "-lower-atomic" would probably be even better but it's already taken by another pass which just replaces all atomic ops with non-atomic ones. Bonus points for coming up with a simple but obvious naming distinction there.
http://reviews.llvm.org/D4958
More information about the llvm-commits
mailing list