Valgrind buildbot failures

Justin Bogner mail at justinbogner.com
Mon Aug 4 10:49:41 PDT 2014


I wrote:
> I don't think this kind of stashing iterator is even a valid bidirectional
> iterator. Nobody needs this to be bidirectional anyway (everything iterates
> once through in one direction or the other) so I guess the simplest fix is
> to split this into two input iterators like in the attached.
>
> WDYT?

Tilmann Scheller <t.scheller at samsung.com> writes:
> Hi Justin,
>
> yeah, I agree that this is definitely not a bidirectional iterator (even
> though it claims to be).
>
> I like your patch, I strongly prefer this solution over the previous
> proposal of making the the original iterator return a value rather than a
> reference.
>
> Regards,
>
> Tilmann

David Blaikie <dblaikie at gmail.com> writes:
> Pity about not being able to use a reverse_iterator (& thus having to
> duplicate bits of the implementation), but I'm OK with that.

Yeah, the code duplication's a bit lame. It's mostly only boilerplate
that's duplicated though, so it's not the worst thing in the world.

Committed in r214737, hopefully that makes the valgrind bots a bit
happier!



More information about the llvm-commits mailing list